Documentation

(visionx)

VisionX Documentation

Version: 5.0 / 2018-05-22

Introduction

VisionX is an open source low-code tool for the efficient development of web-, mobile- and desktop applications. It focuses on database driven applications for businesses that facilitate data management and support processes. The resulting applications are based on open source frameworks such as JVx, Vaadin, Apache POI, iText and others.

VisionX covers the entire application development process, which includes the data model design, the user interfaces, the business logic, the creation of reports, the import and export of data (EXCEL, CSV, XML), the access via web services and much more.

This manual is divided into the following sections:

  • Create/Edit Applications
    • Create Application
    • Create Workscreen
    • GUI Designer
      • GUI Elements/Properties
    • Menu
    • Administration of Users and Roles
    • Application Settings
    • Specification and Data Model
    • Create/Edit Reports
    • Actions
  • Application - Live Preview
  • VisionX Administration
  • Application Export/Import
  • Application Installation

Additional information can be found in the following detail manuals:

  • VisionX Actions.pdf
  • VisionX Installation Instructions.pdf

Create/edit Applications

This chapter describes the main VisionX functions that are used to create and edit applications. It provides an overview of VisionX and shows how to develop a first application.

Create an Application

After starting VisionX, the user is taken to the application overview, in which all applications are shown. Depending on the user license, VisionX is delivered with a number of different sample applications. They can be used to understand the use of VisionX functions, or as a basis for new applications.

The main window of VisionX

The small red “Delete” button on the bottom right is used to delete applications.

Clicking the green “Play” button opens an existing application for editing. All application related functions can be found there. They are explained in Chapter 2 - Create/Edit Applications.

The green “Plus” button in the application list and the button “New Application” are used to create a new application.

The following screen shots demonstrate the creation of a new application.

Create an Application - Step 2 - Title

VisionX offers wizards for all functions, which allow for the step-by-step creation of applications, workscreens, etc. . Most wizards can be completed by clicking the “Finish” button without changing any additional settings, in which VisionX will use the default settings.

In Step 2, the title, folder and description of the new application are added. It should be noted that the application description is entered as text in the specification document as well as the Java source code documentation. This is true for all description fields in VisionX. The description fields should therefore be completed carefully, to create adequate documentation for the application and to maintain a specification document for software providers.

See: Create Specifications / Data Model Report

Create an Application - Step 3 - Database

In Step 3, the database user (=Schema) is entered, which is used by VisionX to store tables and data. Either a new or an existing database user can be selected. The default setting is a new user with the name of the application as user name. A new database connection (=new entry in the list of available databases) can be created using the “New” button, so that additional databases can be used with VisionX.

See: VisionX Administration

Create an Application - Step 4 - Administrator User

In Step 4, the administrator user is defined. This user is used to log in to the newly created application. Additional users for the new application can then be entered in VisionX. It should be noted that since the administrator user has all rights in the application, a secure password should be selected for this user. The default setting is admin/admin.

See: User / Role Management

Clicking “Finish” creates the new application and opens it in the application editor, where additional actions and functions are available to customize the application.

Create an Application - Next Steps

Using the “Next Steps” wizard shown above, the user can create a first workscreen for the application.

Create A Workscreen

The “New Screen” wizard in the application's menu is used to create a new workscreen.

In Step 1, the title, file name and description of the workscreen are entered. It should be noted that the application description is entered as text in the specification document as well as the Java source code documentation. This is true for all description fields in VisionX. The description fields should therefore be completed carefully, to create adequate documentation for the application and to maintain a specification document for software providers.

See: Create Specifications / Data Model Report

Create Workscreen - Step 1 - Title

Create Workscreen - Step 2 - Choose Layout

The workscreen layout is selected in Step 2. The following layouts are available: a table (workscreen with grids), a form (workscreen as form), or a combination of the two. An empty workscreen can also be chosen.

Create Workscreen - Step 3 - Select Data Source

In Step 3, the workscreen's data source is selected.

The following options are available:

  • Transfer data from an existing EXCEL or CSV file
  • Use existing database table(s)
  • Define new database table(s)

Hint: When you create your first workscreen, we recommend that you define a new database table.

See: Create New Database Table(s)

Existing Excel / CSV File

VisionX can import data from an existing excel spreadsheet or CSV file. Alternatively, a table from a spreadsheet or word processor can be copied to the clipboard and then pasted to the wizard's text field.

Create Workscreen - Step 4a - Existing EXCEL /CSV File - Data Definition

It should be noted that only structured tables can be transferred. The transfer of a collection of data with varying amounts of columns per row cannot be guaranteed. Therefore, every table should consist of a fixed number of columns, with appropriate values in every row and column. Columns can also remain empty.

The next step shows how VisionX transfers the table. The data format can be chosen, just as it would in the CSV import function in excel. VisionX attempts to recognize the format automatically as much as possible.

The “Yes/No detection” option can be used to attempt to recognize Yes/No fields (= checkboxes). If this option is selected, columns containing Yes/No or true/false values are recognized as checkboxes.

The “Dropdown detection” option is used to define columns as drop-down lists (combo boxes) if they contain multiple entries of the same value. E.g. Mr., Mrs. The “Dropdown value threshold” defines how many times the same value has to appear before the column is recognize as a drop-down list. “Dropdown grouping” attempts to group similar drop-down lists (in the entire EXCEL/CSV table) into a single list (e.g.: if multiple columns contain salutations).

Create Workscreen - Step 4a - Existing EXCEL /CSV File - Preview

The next step shows the table structure for the database table. On this screen, the description, content, view can be edited, fields can be added/deleted, and the order of the fields can be changed. The functionality here is the same as in section Create New Database Table(s).

Create Workscreen - Step 4a - Existing EXCEL /CSV File - Data

Existing Database Table(s)

To use an existing database table, the first step is to select a database.

Create Workscreen - Step 4b - Existing Database(s) - Select Database

In the next step a table can be selected. VisionX analyzes the data model and includes up to 5 detail tables with the selected master table.

Create Workscreen - Step 4b - Existing Database Tables(s) - Data/Information

This step shows the table structure for the master and detail database tables. Additional information can be found in section Create New Database Table(s).

The field labels for the workscreen can also be edited in this step. In addition, detail tables can be removed. Please note that removing a detail table in this wizard does NOT delete the detail table from the database, it merely ignores the detail table for the purpose of the creating the workscreen.

Create New Database Table(s)

New database tables can easily be created at any time. In the next wizard step, the structure is defined in a table.

To do this, simply enter the column names in the first column (= labels). E.g.:

  • Name
  • Description
  • Project Number
  • From Date
  • To Date
  • Completed Check
  • Select Table

The labels are used as column names in the database table and as labels/headers for table columns and editors in the workscreen (column names are edited by VisionX to conform to ANSI SQL standards - no spaces/special characters).

VisionX attempts to determine the data type/content based on the label. It can then be edited in the “Datatype Name” column if necessary.

Create Workscreen - Step 4c - Create New Database Table(s) - Data/Information

The table name can also be changed. The default setting is the workscreen name.

The “Mandatory” check box defines whether a value is required for the column.

When a new column is added, it has the type of an Input Field by default. The column can be transformed into two other types:

  • Combobox

    The column is displayed as a drop-down list (= combo box). Only values from the drop-down list can be entered. This list is created by adding a master data list with one column (same name as the combo box), which is used to manage the possible values. The “Existing database table(s)” option in the “New Workscreen” wizard can be used to create a master data list for this purpose. In the “Label” column, the master data list's name can be changed, or an existing master data list can be utilized (e.g. User).

    From a technical perspective, a foreign key and a foreign key table column are created in the master table with reference to the master data table. The master data list also receives a unique key via the value column (same name as the combo box), as well as a numerical primary key with the name “ID”.

  • Subtable

    With the “Table” option, a detail table is created instead of a table column. In this detail table, any number of detail records can be stored for each record in the master table (e.g.: a list of ToDo items for each project). See Create Workscreen - Step 4c - Create New Database Table(s) - Data/.

Additional columns can be added to the detail table. They are shown indented below the detail table name.

From a technical perspective a foreign key and a foreign key table column are added to the detail table with reference to the master table. The detail table receives a numerical primary key with the name “ID”.

From a technical perspective, the master table also receives a numerical primary key.

To keep VisionX simple, “ID” and “*_ID” are not shown on the workscreens. However, they can be accessed via actions or via the Java Source Code in a Java IDE.

In Step 5, options for the workscreen layout can be defined.

Create Workscreen - Step 5 - Layout Options

Depending on the selected layout, the number of columns for the input fields/drop-down lists on the form can be selected. The default setting is 2 columns of input fields. Detail tables can be arranged using group panels or tab sets. In addition, for the table layout or the combined table/form layout the split orientation (horizontal or vertical) can be selected.

GUI Designer

Design mode is activated using the “Design” button in the application's menu. In design mode, all open workscreens can be edited. If no workscreen is open when design mode is activated, the GUI Designer opens a list of all available workscreens.

Design mode is closed using the “Finished” button in the application's menu.

GUI Designer - Design Mode

GUI elements can be moved onto the workscreen from the panel on the left side of the screen via drag & drop.

Actions can be reversed and redone using the “Undo” and “Redo” buttons on the toolbar. It should be noted that changes in the GUI Designer are always saved immediately and are executed after the “Finish” button is clicked in a wizard.

The lower panel shows the data model that is currently used. It includes all tables that are used in the workscreen. This panel is used to create or integrate additional tables, edit existing tables, and to move data related elements such as input fields, drop-down lists or tables onto the workscreen via drag & drop.

The center panel is used to edit the layout of the workscreen. Elements can be moved via drag & drop, or adjusted in size. Individual elements or entire areas can be copied by holding the key while an element is dragged.

When a GUI element is selected, two small icons appear on the upper left corner of the element. The first is a trash bin, to delete the element, and the second is a pencil, to edit the element. Depending on the GUI element type, various properties can be edited (e.g.: font, color, orientation, picture, table column labels (F2/Pencil), etc).

See: GUI Elements/Properties

In addition, depending on the GUI Element, a number of events can be utilized. If the respective event occurs when the application is running, a specified action is executed. These actions can be defined and managed using the actions editor.

See: Actions

GUI Designer - Properties

When an element is selected, its name, type and position in the GUI element hierarchy is displayed above the workscreen. In addition, all of the element's anchors are displayed, which can be moved using the triangular handles (top/bottom).

VisionX forms are arranged in the commonly used form layout. All elements are positioned on a grid of rows and columns. An element does not have to be placed exactly in a row or column, it can also stretch across multiple rows, columns, or both. This is done by selecting the element and pulling one of the edges until it is close to the next anchor line. After the element is released, it is spread across two or more columns. In addition, GUI elements can be attached to the edges of the workscreen by pulling the selected edge of the element close to the end of the workscreen and releasing. As a result, these elements are automatically re-sized when the workscreen size is increased or decreased. This layout mechanism ensures that workscreens are adjusted to the client's resolution, which is extremely beneficial in the case of differing screen resolutions or GUI technologies (web, mobile, desktop).

Attaching GUI Element to Workscreen Edge using Anchors

A clipboard is located in the lower left corner of the screen. It contains all deleted or copied elements. They can be pulled into any workscreen via drag & drop, which allows for simple and quick restructuring of workscreens. For example: In a first step all elements are deleted panel by panel to create space. Then the new group elements (e.g. tab sets) are placed on the workscreen and the original panels are replaced step by step. VisionX prevents the deletion of any elements that are used in an action. This ensures that none of the logic is lost. To delete such an element, first the business logic has to be adjusted and the references have to be deleted.

This method can also be used to copy parts of workscreens into other workscreens.

GUI Designer - Data Fields

The lower panel shows all the tables that are used in the workscreen.

For each table, the following data related elements (highlighted in green) can be placed on the workscreen via drag & drop if they are not already used on the screen:

  • Table View
  • Form A group box with all of the table's input fields and drop-down lists.
  • Search Box (= Filter Editor) Search boxes can limit the amount of data displayed in a table. They allow the user to limit data in either all or selected table columns e.g.: full text search, smaller/greater/similar/… filter by project number, name/…
  • All input fields/drop-down lists (= editors) not currently in use on the workscreen. The toolbar on the left of the lower panel also includes a button for the table documentation, where descriptions can be added for the table and each of its columns. The descriptions are stored in the database as table and column comments and are used for the specification and for the data model documentation.

The “Pencil” symbol is used to edit the data structure of the table and its detail tables.

GUI Designer - Edit Data Model

The “Edit Data Object” wizard allows the user to add, delete or edit tables/table columns. Changes made in this wizard are not effective until the “Finish” button is clicked, and can be discarded using the “Cancel” button.

If the description is changed, the respective table column is renamed.

If the data type (content) is changed, VisionX attempts to change the data type in the database.

Depending on the data type and the database provider this is only possible to a limited extent. E.g.: a conversion from “text short” to “text long” is possible, but a change from “text short” to “number” is only allowed if the column only contains valid numbers or no values at all.

In addition, a table column can be changed to be a required field and conversely. Limitations similar to those for data type changes apply - the change to a required field is only possible if all columns contain values.

Deleting a table or table column means that the data in the table or column is also deleted!

When columns are added, it should be noted that all existing records a populated with blank values.

Therefore a newly added column can initially not be a required field. The column can be changed to a required field only after values are added in the column for all rows.

All changes to the data model are made step by step. In case a database change is not possible, the remaining changes are not made. All data model transformations are completed in multiple steps.

The original data is not deleted until all steps are successfully completed. The drop-down lists' original master data tables remain in the data model! If a column's data type cannot be changed, the original data type including all data is preserved.

For tables or columns that are already used in actions, data-related GUI elements or other workscreens, please note that the references are NOT corrected automatically. If such references exist, they are displayed in the GUI Designer (design mode) in red. The “Edit Data Object” wizard for the respective table can be used to attempt to delete these references to maintain an error free workscreen.

GUI Elements/Properties

The following table shows all GUI elements and their properties that require explanation. In addition, all GUI element properties can be edit via Java code in a Java IDE, such as Eclipse. Additional information can be found in the documentation for the JVx Open Source framework on the internet.

GUI Element Description
Label Label for input fields, etc.
Picture Pictures can be added to the application using the picture library. A selection of images is included in VisionX.
Button
Toggle Button
Buttons usually trigger certain actions and can be used to display images and text. A Toggle Button is a button with two states (clicked, not clicked).
Radio Button
Check Box
Option button and check box for the selection of one or more values.
Option Chooser This element is a panel containing radio buttons. This GUI element has to be associated with a combo box table column. A radio button is created on the panel for each possible value on the drop-down list. Only one value can be selected. This element allows for the effortless creation of data-related radio groups.
Field Validator Field validators are status fields that show whether the field validation for an associated table column was successful or not (green checkmark or red “X”).

This GUI element has to be associated with a table column; the validation related to the column has to be created using the action editor.

The “Automatic validation” option immediately performs the validation VisionX Documentation 23 when the field is exited (this is the default setting). Otherwise the validation has to be initiated using the “Are Validations Ok” condition in an action (e.g. upon click of a “Save” button on the form).

When the “Hide until first validate” option is selected, the validation field's status is not displayed until the validation has been performed. Otherwise it is displayed at all times.
Validation Result This element displays validation errors that resulted from failed field validations. The associated GUI element determines which field validations are considered. All field validations on the same Panel/Split or tab are considered.
Panel A panel can contain other GUI elements or sub elements. Sub elements are arranged form oriented by rows and columns.
See: GUI Designer
Group Panel A group panel can contain other elements as sub elements. In addition, this element has a frame and a title. Sub elements are arranged form oriented by rows and columns.
See: GUI Designer
Horizontal Split
Vertical Split
A split can contain exactly two elements as sub elements. The sub elements are separated horizontally or vertically by a moveable bar.
Tabset A tab set can contain other elements as sub elements. Each sub element is displayed as a tab with a label.
Tree One or more tables are displayed as trees. The used columns can be choosen.
Table View A database table is displayed as a table including navigation containing New/Edit/Delete/CSV Export options.

The column order, labels, and visible columns can be specified. An alternate column order and visibility can be specified for the display on mobile devices.

In addition, the default sort setting can be determined via click (and Ctrl Shift + click) on the column headers.
Input Field
Dropdown List
Editor
A data-related table column is displayed as input field or drop-down list.
Search
(Filter Editor)
Search boxes can limit the number of results in a table. Either all columns or a selected number of columns can be restricted using the selected search criteria. e.g.: full text search, smaller/greater/similar/… e.g. search for project number, name, …

The “Menu” dialogue in the application's menu is used to manage the menu.

Menu Management

The menu management wizard is used to create new menus or sub-menus and to edit existing menus. Menu entries (workscreens) can be sorted or moved to different menus using the arrow buttons.

The menu title, and with it the name of the workscreen, can be changed in the panel on the right. If a toolbar title and picture are added, the menu entry is also displayed in the application's toolbar. A hot key can be defined to quickly open the menu entry.

User / Role Management

Every application created with VisionX comes with a standard user management tool, which can be edited using the VisionX functions to meet specific requirements. It can also be used to manage the application's users. The user management tool is part of the application and can be used without VisionX.

User Management

By default, the user management tool is located in the “Admin” menu.

In addition to user name and password, additional information can be recorded for each user. The “Active” checkbox determines whether the user is currently active and is able to log in to the application. Checking the box “Password expired” forces the user to change passwords at the next login.

Roles can be defined for each user by checking the respective boxes in the “Roles” table. The roles itself are managed using the application's menu.

See: User / Role Management

Application Settings

A number of application settings can be edited in the “Application Settings” menu of the application's menu.

Application Settings - Details

On the “Details” tab, the application's title, version, language and additional information can be entered and edited.

The default setting for the language is “Automatic”. This means that the application is opened using the client PC's language. Instead, a specific language can be selected in which the application is to be run (e.g. English).

If not translation is available for the selected/determined language, the respective text is not translated and remains unchanged.

On the “Start” tab, a standard user can be defined for automatic authentication. This can be used for public applications without registered users.

In addition, a welcome workscreen can be selected that is displayed automatically when the application is opened.

Application Settings - Start

On the “Design” tab, the background, application icon (the icon on the top left of the workscreen), as well as the preview image for the VisionX application overview can be selected.

Application Settings - Design

Application Settings - Manage Roles

On the “Roles” tab, new roles can be created, and roles are assigned to the available workscreens. Role-specific functionality can also be managed on the workscreens directly, e.g. actions can be used to show/hide certain fields or buttons.

Additional information can be found in the VisionX Actions Documentation.

Application Settings - Datasources

The “Datasources” tab shows all data sources that are used in the application. They can be edited on this tab if a database/database user was changed or moved to a different server.

“Default” refers to the main database connection, which also contains the users, roles, workscreens, etc. that are required by VisionX.

See: VisionX Administration

On the “Translation” tab, the application's languages and the corresponding translations are edited.

When the application is created, all workscreens, menus, etc. should be in the same language (= default language). This can be English, German, etc. Additional languages and their translations can be created and managed on this tab. The “Not translated” button is used to transfer all recognized text for which no translation exists to the translation list. On this list, a translation can be entered for each message. This allows the user to add missing translations for new workscreens or functions at any time.

For VisionX to recognize the text, all workscreens first have to be opened and all functions executed. Irrespective thereof, further text and translations can always be added.

Application Settings - Translation

In addition to simple text, placeholders can be used for error messages. This is particularly helpful for error message that refer to fields, etc.

Text The field “*1” in Tab “*2” cannot be empty!
Translation Das Feld ‚*' in Reiter ‚*' muss befüllt werden!

* can be used to define placeholders.

The translation can include a reference to the placeholder themselves. That's done with the * followed by a number. e.g.: *1 for the first placeholder.

Create Specifications / Data Model Report

The “Specification” wizard in the application's menu is used to create specification documents.

Create Specification / Data Model - Select Option

In the first step, the user can choose between a specification document for the application's workscreens or the documentation for the database.

For the application screen documentation, a word document is created containing a description of the application, of the workscreens (including a screen shot), and of all fields and their respective actions.

For the database documentation, a word document is created showing all database tables including all columns, primary keys, foreign keys and unique keys.

Both options are created based on a template, which is downloaded in the next wizard step and edited using Microsoft Word. The template system is the same as the one used for the VisionX reports.

See: Create / Edit Reports

Create Specification / Data Model - Select Template/Workscreen

Created Specification

Create Help

The “Create help” wizard in the application's menu is used to create or expand the application's help pages.

Create Help - Options

In this step, the user can create new help pages or add additional workscreens to existing sections. In addition, the application image in the help pages can be edited.

In both cases the help pages can easily be edited in any HTML editor, to add more details or examples.

The help function in VisionX is HTML based, including indexed full text search.

In the next step, the user can select the workscreens for which the help documents are to be created.

Create Help - Select Workscreens

Create / Edit Reports

The “Reports” wizard in the application's Funktionsmenü is used to create a new report or to edit an existing report.

Create Reports - Step 2 - New or Existing Report

Since reports are managed by workscreen, the first step in the wizard is the selection of a workscreen.

In the second step, creating a new report or editing an existing report can be chosen.

One of the following report formats is selected in step three:

  • Document (=Word RTF Format)
  • Spreadsheet (=EXCEL XLS Format)
  • XML

Depending on the VisionX license, certain formats may not be accessible, or additional formats may be available.

In addition, one of the following report layouts can be chosen:

  • Simple List A table is displayed as a simple list. The current data filter is applied.
  • List with Details A table is displayed as a list, in which for each master record a list of all detail records is shown. The current data filter is applied.
  • Form (with Details) The currently selected master record is displayed as a form, below which detail tables can be shown.

Create Report - Step 3 - Select Layout

In the next step, the master table (highest level table in the report) can be selected.

Create Report - Step 4 - Select Data/Master Table

Depending on the layout, a number of options can be selected. This is particularly relevant for the “List with Details” format. The following options are available:

  • Checkbox “Show records only for selected master” If this option is checked, only the selected master record and the respective detail records are displayed in the report.
  • Checkbox “Show master records only for its selected master” If this option is checked, all detail records are displayed for all visible master records.
  • None of the two options are checked If there is another level above the master record, no restrictions apply to this additional level. E.g.: For the report, State (master) and City (detail) are selected; the table State has a master table Country In this case, the report shows all states (for all countries!) and every city for each state

Create Report - Step 5a - Select Master Columns

Create Report - Step 5b - Select Detail Columns

In the last step, the columns that are to be displayed in the report can be chosen for each table. As an option, the detail columnscan be selected for the report in addition to the master columns.

Create Report - Assign "Show Report" Action to a Button

In this step, the newly created report can be assigned to a button. An action is automatically created, or an existing action is edited, to show the report.

The “Reports” wizard can also be used to edit existing reports.

Edit Report - Change Layout

To edit an existing report, the report template is downloaded and edited using Microsoft Word, Excel, XML, or any other suitable editor and then uploaded back to the application.

The templates are based on placeholders, which are populated with data from the database tables when the report is created.

Additional information about reports and templates can be found in the VisionX Reports Documentation.

Actions

Actions are created, edited and deleted via VisionX's GUI designer. They can be used for a number of events, such as, for example, the click of a button. When the selected event occurs during the use of a workscreen, the respective action is performed.

Example:

When the event “button click” occurs, the specified action is executed. For example, the action can show a a report.

The following steps show how a report is displayed after the click of a button labeled “Report”.

Define Action

The following steps demonstrate the definition of a simple action.

Example:

Displaying a report by clicking a button labeled “Report”.

  • Step 1 - Open a workscreen in the GUI Designer - e.g.: the “Contacts” workscreen

  • Step 2 - Select the “Report” button in the GUI Designer and click on the pencil icon

    Edit Actions - Step 2

  • Step 3 - Click on the button “Create/Edit Action” to create/edit an action

    Edit Actions - Step 3

  • Step 4 - Enter a description of the action on the “Description” tab

  • Step 5 - Click on the “Action” tab and select “Show Report”

    Edit Actions - Step 5

  • Step 6 - Select the desired report as parameter

    Edit Actions - Step 6

  • Step 7 - Click the “Verify” button and then “OK” to verify and save

This completes the action. It can be tested by closing the GUI Designer and changing to runtime mode. Clicking the “Report” button opens the “Contacts” report.

Additional information about actions can be found in the VisionX Actions Documentation.

Events

The following table summarizes all events that can be defined in VisionX. The availability of these depends on the GUI element to which they are applied. Furthermore, additional events can be defined using Java code in a Java IDE, such as Eclipse. Additional information can be found in the documentation for the Open Source Framework JVx on the internet.

Event Description
On Load This event occurs when a workscreen is opened. It it used to configure the data and elements that are to be displayed.
For example, user or role dependent views can be defined here.
At the time of the event, the workscreen is not yet visible.
GUI Elements: Workscreen
On Show This event occurs immediately after a workscreen is opened. It is used to configure the data and elements that are to be displayed.
At the time of the event, the workscreen is visible.
GUI Elements: Workscreen
On Activate This event occurs each the a workscreen is activated using the “Open Screen” action, irrespective of whether the workscreen is opened or a previously opened workscreen is brought back to the foreground.
It can be used, for example, to evaluate parameters transferred from the called workscreen and to display the resulting values.
At the time of the event, the workscreen is not yet visible.
GUI Elements: Workscreen
On Close This event occurs before a workscreen is closed. It is used to save data or to prevent closing the workscreen.

GUI Elements: Workscreen
Tab Activated This event occurs when a tab is activated. It can be used to perform calculations or validations.

GUI Elements: Workscreen
Action This event occurs at the click of a button.
It is used to start processes, execute logic, manipulate data, display reports or import data.

GUI Elements: Button, Toggle Button, Radio Button Check Box
Row Value Changed This event occurs upon the change of a value in a row. There is only one value change event per table. Irrespective of which GUI element is used to open the wizard, the event is always the same.
The condition “Is Column Changed” is used to determine which value has changed.
This event can be used to calculated dependent values.

GUI Elements: Table, Editor
After Row Selected This event occurs after a row is selected in a table. There is only one “After Row Selected” event per table. Irrespective of which GUI element is used to open the wizard, the event is always the same.
This event can be used to show/hide components, calculate values, or activate/deactivate buttons dependent on the data in the selected row.
GUI Elements: Table, Editor
After Inserting Row This event occurs after a row is inserted in a table. There is only one “After Inserting Row” event per table. Irrespective of which GUI element is used to open the wizard, the event is always the same.
This event can be used, for example, to fill a newly inserted row with standard values.

Application - Live Preview

VisionX Live Preview can be used to run an application.

Live Preview - Select Application

After an application has been selected, the platform on which the application is run can be chosen.

Depending on the VisionX license, the following options are available:

  • Desktop The application is run as a desktop Java application (just like any other Windows/Linux/MacOS application).
  • Java in a Browser The application is run as an Applet/Webstart Java program in a web browser. For this to work, Java (including the Java plugin) has to be installed on the client.
  • HTML5 in a Browser The application is run as an HTML5 application in a web browser.
  • Mobile Device The application can be used as a native iPhone/iPad or Android App on a smartphone or tablet. For this to work, the VisionX Preview App has to be installed on the mobile device.

The user interfaces of the VisionX application are similar, although certain technology specific variations will occur depending on the respective GUI Platform and Open Source Framework.

Live Preview - Select Mode/Platform

In the next step, the URL for the manual start of the application is displayed. For mobile applications, the QR code containing the configuration details can simply be scanned to be transferred to the mobile device.

Live Preview - Start Details

VisionX Administration

The data sources (=database connections) for VisionX are managed on the “Administration” tab.

Here the data source name, the desired database (Oracle, MySQL, DB2, MS SQL, PostgreSQL), as well all the the relevant database connection parameters are specified. These parameters include the server (name or IP), port, as well as the database name (or SID in Oracle).

In addition, a valid database user name and password have to be entered.

The “Test Connection” button is used to test the connection to the database.

Admin Datasources

For the data sources, VisionX distinguishes between admin data sources and user-defined data sources (menu item “Datasources”). The difference lies in the rights of the respective database users.

For admin data sources, a user with administrator rights is required, so that VisionX can create new database users with this user. This is used in the “New Application” wizard to create a new database user for the new application.

During the installation of VisionX, one admin data source with the name VisionX is configured. It is used by VisionX to manage its own data. In the desktop edition, an embedded database is used for this purpose, whereas in the enterprise edition a database can be selected during the installation process. This database is used to save data such as the VisionX users, admin data sources, user- defined data sources, etc. User-defined data sources only require the usual database user rights. They are used to integrate external databases into VisionX applications, e.g. to use certain master data in the application. They can also be used to work with a user prepared by the database administrator when a new application is created.

New Application - Select Database

As mentioned in Chapter Create an Application, either a new or an existing database user can be selected for a new application. The default setting is the “VisionX” admin data source. If a new database user is selected, VisionX creates a new user using the selected admin data source. For this reason, only admin data sources can be selected for this option.

Under the second option - “Reuse an existing Database User”, a user can be selected from the list of available database users for the chosen admin data source. This user is then utilized for the new application.

Under the third option, a user-defined data source can be selected, which is then used by VisionX for the new application.

New data sources (= database connections) can be created using the “New” button. For options 1 and 2 the admin data source workscreen is opened in this case, whereas the “New” button next to the third option opens the workscreen for user-defined data sources.

When a new workscreen is created, or when a new table is integrated into a workscreen, a similar screen is available for the selection of a database. It includes the option “Use Application Database User” to make tables available from the application's database connection. This is the default data source shown under the “Datasources” tab of the “Application Settings” menu (see Application Settings).

The VisionX user management workscreen can be accessed on the “Tools” tab.

VisionX Users

The users shown in this workscreen are the VisionX users and NOT the users of the individual applications. This workscreen is relevant when the VisionX Enterprise Edition is run on an application server. In this case all VisionX users have to be defined on this workscreen.

VisionX hat three roles:

  • Administrator - to manage the VisionX users
  • User - for the regular use of VisionX
  • Developer - to display the Java source code editor in the VisionX actions editor

Application Export / Import

Applications can be exportet and imported using the “Export” and “Import” functions on the “Tools” tab.

This feature is used to create backups of applications or to send an application to a software developer for further advancement.

Exchange process with the software developer:

  1. Export the application
  2. The software developer creates the added functionality based on a specification document
  3. Import the application

Export Applications

To export, the application and export type are selected. The following options are available:

  1. Complete The database and the application, including all libraries, are exported.
  2. Update Only the application is exported, with libraries (smaller file size).
  3. Database Only the database is exported.

For the export types “Complete” and “Database”, the option “Export Database Records” determines whether the tables' data is also exported. Also for the export types “Complete” and “Database”, the option “Export Database Objects” determines if the tables and views are exported.

In general, it should be noted that during the database export, VisionX only exports the tables and views. An accurate export/import of the views is only provided for simple ANSI SQL conform views.

Database system specific and proprietary objects are not considered during the export/import.

The application export is provided as a .ZIP file.

Import Application - Step 1 - Configuration

For the import, a valid VisionX export file and an application name are required.

The application can be imported as a new application or over an existing application. The latter option overwrites the existing application!

In the second step, a selection is made as to which content from the export file is imported. If the “Database” option is unchecked, the database - if it is included in the export file - is not imported into VisionX.

The third step shows the application's data sources based on the information in the export file. They can be edited by the user. Data can be imported for either a new or an existing database user. It should be noted that if an existing database user is selected, the existing tables and data are overwritten!

See: VisionX Administration

Import Application - Step 3 - Verify Data Sources

If the database is imported, an option is available in the fourth step to determine whether the data is imported as well (“Import Data” option).

The option “Delete and recreate database objects” is used to deleted existing database objects before the import.

Import Application - Step 4 - Database Settings

Application Installation

To install the application on an application server, the “Installation” function on the “Tools” menu is used.

Install Application - Step 1 - Select Installation Mode

In the first step, a selection is made whether only the application, the database, or both should be installed.

Each VisionX application consists of an application and a database. The application contains workscreens, actions, reports and functions. The database contains the tables, views, and data.

The application is installed on an application server, while the database is installed on a database server.

The users can run the installed application with their PCs. This can be done, for example, by entering the application's URL in a browser. After the application is started, the user enters log-in credentials and is then able to access the relevant workscreens via the application menu.

The following figure shows an overview of the application's system architecture.

System Architecture - Application

In the following step, the application server for the installation of the application is selected.

The following application servers are supported:

  • Apache Tomcat
  • JBoss Application Server
  • Cloudbees (Cloud Application Services)
  • Oracle Glassfish

If the required application server is not on this list, a “Web Application Archive” (= WAR file) can be created instead. This file can then be installed manually via the application server's configuration interface. Depending on the VisionX license, it is possible to create a .WAR file for the installation of Liferay Portlets and/or webservices.

Application Installation - Step 2 - Select Application Server/Installation Type

If an application server is selected, the relevant parameters are entered in the next step. In addition to a name, the version, server (name/IP), port, user name, password and manager path need to be entered. The application path can also be edited.

Application Installation - Step 3 - Application Server Settings

The database is installed in the next step, where either a new or an existing database user is selected.

See: VisionX Administration

Application Installation - Step 4 - Select Database

In the following step, the option “Delete and recreate database objects” can be used to delete the database objects of the selected user before the import. The “Import Data” option is used to import the data from the export file.

Application Installation - Step 5 - Database Settings

This website uses cookies for visitor traffic analysis. By using the website, you agree with storing the cookies on your computer.More information