Documentation

Trace: Build release

(flutterui)

Build release

Build script

Requirements

The build script requires Node.js and perl. Simply check versions:

node -v
npm -v

perl -v

Download and install Node.js: https://nodejs.org/en/
Download install Perl: https://www.perl.org/get.html

Run npm install to install all depending npm packages.

(Windows only) Add the full path of flutterclient/node_modules/.bin/ to %PATH% variables.

Commands

The results can be found in deploy directory.

Web

Currently, beta channel is required for Flutter WEB:

flutter channel beta
flutter doctor -v
flutter config --enable-web

Start build

npm run buildweb

Android

npm run buildandroid

iOS

npm run buildios

Build number

npm run increasebuildnumber  

Manual

Web

Currently, beta channel is required for Flutter WEB:

flutter channel beta
flutter doctor -v
flutter config --enable-web

Run the web variant:

flutter run -d chrome  

Build the release:

flutter build web

The result can be found in build/web directory.

This website uses cookies for visitor traffic analysis. By using the website, you agree with storing the cookies on your computer.More information